How to upgrade JDK in Oracle Database 11.2.0.4.0 #jdk #oracle

Channel Avatar
Comment
X
Share
How to upgrade JDK in Oracle Database 11.2.0.4.0 #jdk #oracle
How to upgrade JDK in Oracle Database 11.2.0.4.0 #jdk #oracle
In this video we will learn How to Upgrade JDK in Oracle Database 11.2.0.4.0 from 1.5 to 1.7.

Follow the below steps to update the JDK with Oracle Database 11.2.0.4.0.

Check JDK version.

ORACLE_HOME/jdk/bin/java -version

Currently we have 1.5.0_51 jdk installed in our database..

Now we will upgrade it to jdk 1.7.

By default, the following #Java JDK major versions were shipped with

each Oracle database version:

Oracle 11.2.0.4       Java 5 (updated to Java 7 with patch 25803774)
Oracle 12.1.0.2       Java 6 (updated to Java 7 with patch 27301652)
Oracle 12.2.0.1       #Java 8
Oracle 18c                Java 8
Oracle 19c                Java 8

As per oracle support.

We will have to apply patch 25803774 in our oracle home….

We have already downloaded the patch and moved it on db server….

Now we will check the README.html of patch 25803774 to apply this patch…

Checking pre requisite to apply this patch..

opatch prereq CheckConflictAgainstOHWithDetail -ph ./

After executed the prereq of this patch we are facing below error…

Unable to create Patch Object.
                             Exception occured :

/data05/EBS_Patches/JAVA_PATCH/25803774/etc/c
onfig/actions.xml with Version field of the component delete in actions

file cannot be null or empty. Please check patch metadata.

Above error coming because of OPatch version…

Our current opatch version is 11.2.0.3.15.

As per doc 2320940.1  we need to update opatch verson .

For 11.2 Database, select Release as Oracle 11.2.0.0.0

OPatch can be downloaded here:

https://updates.oracle.com/download/6880880.html

we already downloaded the patch 6880880.

unzip the opatch patch and copy it at ORACLE_HOME

OPatch version    11.2.0.3.15

opatch version

OPatch Version: 11.2.0.3.28
OPatch succeeded.

Now we have OPatch Version 11.2.0.3.28

OPatch Error Exception occured Your Oracle Home has a constituent installed without having its prereqalso installed. occurs despite

referenced directory existing in oneoffs (Doc ID 2320940.1)

opatch prereq CheckConflictAgainstOHWithDetail -ph ./

Oracle Interim Patch Installer version 11.2.0.3.28
Copyright (c) 2021, Oracle Corporation.  All rights reserved.

PREREQ session

Oracle Home       : /data03/UAT_8026/orahome
Central Inventory : /etc/oraInventory
from           : /data03/UAT_8026/orahome/oraInst.loc
OPatch version    : 11.2.0.3.28
OUI version       : 11.2.0.4.0
Log file location :

/data03/UAT_8026/orahome/cfgtoollogs/opatch/opatch2021-02-

27_11-45-48AM_1.log

Invoking prereq checkconflictagainstohwithdetail

Prereq checkConflictAgainstOHWithDetail passed.

OPatch succeeded.

See the above Pre-requisite has been succeeded.

Here we will apply the patch .

opatch apply.

Oracle Interim Patch Installer version 11.2.0.3.28
Copyright (c) 2021, Oracle Corporation.  All rights reserved.

Oracle Home       : /data03/UAT_8026/orahome
Central Inventory : /etc/oraInventory
from           : /data03/UAT_8026/orahome/oraInst.loc
OPatch version    : 11.2.0.3.28
OUI version       : 11.2.0.4.0
Log file location :

/data03/UAT_8026/orahome/cfgtoollogs/opatch opatch2021-02-27_11-46-32AM_1.log

Verifying environment and performing prerequisite checks…
OPatch continues with these patches:   25803774

Do you want to proceed [yn]
y
User Responded with: Y
All checks passed.

Please shutdown Oracle instances running out of this ORACLE_HOME on

the local system.
(Oracle Home /data03/UAT_8026/orahome)

Is the local system ready for patching [yn]
y
User Responded with: Y
Backing up files…
Applying interim patch 25803774 to OH Yo/data03/UAT_8026/orahome

Patching component oracle.jdk, 1.5.0.51.10…
Patch 25803774 successfully applied.
Log file location:

/data03/UAT_8026/orahome/cfgtoollogs/opatch/opatch2021-02-27_11-46-32AM_1.log

OPatch succeeded.

ORACLE_HOME/jdk/bin/java -version

java version 1.7.0_141
Java(TM) SE Runtime Environment (build 1.7.0_141-b11)
Java HotSpot(TM) 64-Bit Server VM (build 24.141-b11, mixed mode)

#jdk #jre #upgradejdk #java

Thank You.

Take the opportunity to connect and share this video with your friends and family if you find it useful.

Read Also

Leave a Reply

Your email address will not be published. Required fields are marked *